Commit 5bf8eefc authored by Tim Steiner's avatar Tim Steiner
Browse files

[gh-720] Update UNL Varnish module to call varnish_purge() to be compatible...

[gh-720] Update UNL Varnish module to call varnish_purge() to be compatible with both 2.1 and 3.0. @1h00
parent 07494805
......@@ -60,7 +60,7 @@ function unl_varnish_purge_submit($form, &$form_state) {
*/
function unl_varnish_purge_all_sites_submit($form, &$form_state) {
$path = $form_state['values']['varnish_path'];
_varnish_terminal_run("purge.url $path");
varnish_purge('.*', $path);
drupal_set_message("Varnish purged paths matching $path.", 'status');
}
......@@ -150,6 +150,6 @@ function unl_varnish_purge_all_pages() {
$host = parse_url($alias, PHP_URL_HOST);
$path = parse_url($alias, PHP_URL_PATH);
_varnish_terminal_run("purge req.http.host ~ $host && req.url ~ ^$path");
varnish_purge($host, $path);
}
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment