Commit 502ab1c0 authored by Christopher A. Bohn's avatar Christopher A. Bohn
Browse files

You don't need to install canvasapi unless running your own Linux box

parent cf9de52c
...@@ -7,6 +7,11 @@ selected courses. ...@@ -7,6 +7,11 @@ selected courses.
### Dependencies ### Dependencies
You can use this tool either from the cse.unl.edu Linux server or an another
Linux installation that you control.
If (and only if) you download and run the tool on your own Linux system, then:
- [x] You need Python. I think Python 3.6 and newer will work fine. - [x] You need Python. I think Python 3.6 and newer will work fine.
- [x] You need the `canvasapi` module. Run - [x] You need the `canvasapi` module. Run
...@@ -14,6 +19,11 @@ selected courses. ...@@ -14,6 +19,11 @@ selected courses.
pip install canvasapi pip install canvasapi
``` ```
If you run the tool from cse.unl.edu then you can launch it from your
cse.unl.edu account with the command `~cabohn/abet-oat/analyze_grades.py`.
Either way, you will need a Canvas API key.
### Getting a Canvas API Key ### Getting a Canvas API Key
To interface with Canvas, you need a Canvas API Key. To interface with Canvas, you need a Canvas API Key.
......
File mode changed from 100644 to 100755
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment